- we're experiencing issues with Gitlab integrated templates - this might affect your deployments or gitflow triggers – Incident details

GitLab Git Operations experiencing partial outage

we're experiencing issues with Gitlab integrated templates - this might affect your deployments or gitflow triggers

Resolved
Partial outage
Started almost 4 years agoLasted 2 days
Updates
  • Resolved
    Resolved

    We've rolled out the fix that will allow GitLab tokens to be refreshed. You will need to re-authenticate your using GitLab user/bot with env0 by editing the Template in env0 that integrates with that GitLab user, click the "authorize another GitLab user" and authorize with your user/bot again. Once again we're terribly sorry for the inconvenience - we're in touch with GitLab trying to understand how it came to pass that we were not alerted about this change in their API to avoid such future incidents.

  • Update
    Update

    GItLab.com (the Saas) updated their version to 15.x. which deprecates our authorization approach. We are working on a solution, in the meantime, if you must use GitLab you can re-authorize by going into the template, selecting "authorize another Gitlab user"

  • Identified
    Identified

    we're experiencing issues with Gitlab integrated templates - this might affect your deployments or gitflow triggers