- Delays in Deployments – Incident details

All systems operational

Delays in Deployments

Resolved
Partial outage
Started almost 3 years agoLasted about 5 hours

Affected

Management Console

Operational from 7:33 AM to 7:33 AM, Partial outage from 7:33 AM to 12:39 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved.

  • Update
    UTC
    Update

    A fix was implemented and we are trying to monitor if the issue is resolved.

  • Identified
    UTC
    Identified

    The issue has been identified and we are working on a fix.

  • Update
    UTC
    Update

    We are continuing to investigate the issue together with AWS support. It looks like this is an issue with our EKS cluster. Customers who are using the Self-hosted agent should not be affected.

  • Investigating
    UTC
    Investigating

    We are seeing a lot of deployments delays. At first look, it seems to be coming from AWS Step function API where we are getting a lot of network errors and timeouts. We are currently contacting AWS to find out what is the root cause of this issue.