Issues in env0

Incident Report for env0

Resolved

Resolved, we'll continue to investigate and monitor
Posted Aug 26, 2025 - 13:35 UTC

Update

Slowness and other issues had dropped, we're monitoring the situation
Posted Aug 26, 2025 - 12:53 UTC

Investigating

We're currently investigating environment management and slowness in the env0 system
Posted Aug 26, 2025 - 12:35 UTC
This incident affected: env0 Application and env0 API.