Issues with deployments in env0

Incident Report for env0

Resolved

We've identified some load on our cluster earlier, it has since subsided, and the issue is now resolved.
Posted Jul 28, 2025 - 09:36 UTC

Update

We are continuing to investigate this issue.
Posted Jul 28, 2025 - 09:09 UTC

Investigating

We are currently investigating this issue.
Posted Jul 28, 2025 - 09:08 UTC
This incident affected: env0 Application.