We are currently monitoring the situation. The rate of delayed deployments in env0 was greatly reduced, and we are currently monitoring to make sure that everything is back to normal
Posted Aug 21, 2025 - 12:21 UTC
Update
Please perform a hard refresh of your page as soon as possible.
Posted Aug 21, 2025 - 11:51 UTC
Identified
Our team has identified the issue. Please perform a hard refresh of your page as soon as possible. We apologize for the inconvenience.
Posted Aug 21, 2025 - 11:09 UTC
Investigating
We are currently investigating an issue where deployments in the env0 app are not starting, are delayed, or are failing with an error.