Environment management issue

Incident Report for env0

Resolved

The incident has been resolved, environment management and deployments are operational
Posted Aug 26, 2025 - 16:53 UTC

Monitoring

The fix has been applied and we'll continue to monitor the situation
Posted Aug 26, 2025 - 16:17 UTC

Identified

We've identified the issue and the fix is currently being applied
Posted Aug 26, 2025 - 16:12 UTC

Investigating

We're investigating environment management and slowness in the env0 system, which occurred earlier today and started again
Posted Aug 26, 2025 - 14:51 UTC
This incident affected: env0 Application and env0 API.